Back to Blog Home
← all posts

An up-to-date listing of NativeScript plugins with 7.0 compatibility that we know of.

August 31, 2020 — by Technical Steering Committee (TSC)

You can check back here for any changes as this list will be updated from time to time. As always check with plugin author to see if they brought compatibility and had not notified anyone yet.

You can also request a plugin be updated which you're using as we can help submit pull requests and otherwise talk to the author to help. Drop a github issue about it anytime or comment below.

You can refer to this NativeScript 7 plugin update guide to contribute to any plugin yourself and/or assist an author.

  • All @nativescript-community/ui-material* plugins (material)

  • All nativescript-ui-* plugins (autocomplete, calendar, chart, dataform, gauge, listview, sidedrawer)

  • @nativescript-community/drawingpad: "~4.0.0"

  • @nativescript-community/ui-collectionview: "~4.0.0"

  • @nativescript/animated-circle: "~1.0.0"

  • @nativescript/appavailability: "~2.0.0"

  • @nativescript/appsync: "~3.0.0"

  • @nativescript/appversion: "~2.0.0"

  • @nativescript/auto-fit-text: "~1.0.0"

  • @nativescript/background-http: "~5.0.0"

  • @nativescript/brightness: "~2.0.0"

  • @nativescript/camera: "~5.0.0"

  • @nativescript/datetimepicker: "~2.0.0"

  • @nativescript/directions: "~2.0.0"

  • @nativescript/email: "~2.0.0"

  • @nativescript/fingerprint-auth: "~7.0.0"

  • @nativescript/firebase: "~11.1.0"

    Breaking changes:

    • import { firebase } from @nativescript/firebase vs. import * as firebase from @nativescript/firebase
  • @nativescript/geolocation: "~7.0.0"

  • @nativescript/hook: "~1.0.0"

  • @nativescript/imagepicker: "~1.0.0" (replaces nativescript-imagepicker)

  • @nativescript/iqkeyboardmanager: "~2.0.0"

  • @nativescript/localize: "~5.0.0"

  • @nativescript/local-notifications: "~5.0.0"

  • @nativescript/secure-storage: "~3.0.0"

  • @nativescript/shared-notification-delegate: "~1.0.0"

  • @nativescript/social-share: "~2.0.0"

  • @nativescript/theme: "~3.0.0

  • @nativescript/zip: "~5.0.0"

  • @nstudio/nativescript-cardview: "~2.0.0"

  • @nstudio/nativescript-checkbox: "~2.0.0"

  • @nstudio/nativescript-exoplayer: "~5.0.0"

  • @nstudio/nativescript-filterable-listpicker: "~3.0.0"

  • @nstudio/nativescript-floatingactionbutton: "~3.0.0"

  • @nstudio/nativescript-https: "~3.0.0" (This may end up scoped under @nativescript soon - es2017 build of nativescript-https)

  • @nstudio/nativescript-mapbox: "rc"

  • @nstudio/nativescript-pulltorefresh: "~3.0.0"

  • @nstudio/root-detection: "~2.0.0"

  • @nstudio/nativescript-snackbar: "~2.0.0"

  • @nstudio/nativescript-mixpanel: "~3.0.0"

  • @nstudio/nativescript-loading-indicator: "~4.0.0"

  • nativescript-advanced-webview: "~6.0.0"

  • nativescript-audio: "~6.0.0"

  • nativescript-auth0: "~4.0.0"

  • nativescript-android-sensors: "~2.0.0"

  • nativescript-barcodescanner: "~4.0.0"

  • nativescript-carousel: "~7.0.1"

  • nativescript-clipboard: "~2.0.0"

  • nativescript-feedback: "~2.0.0"

  • nativescript-gif: "~5.0.0"

  • nativescript-image-filters: "~4.0.0"

  • nativescript-insomnia: "~2.0.0"

  • nativescript-lottie: "~5.0.1"

  • nativescript-phone: "~2.0.0"

  • nativescript-plugin-appsflyer: "~6.0.0"

  • nativescript-signalr-core: "~2.0.0"

  • nativescript-speech-recognition: "~2.0.0"

  • nativescript-texttospeech: "~3.0.1"

  • nativescript-vibrate: "~4.0.0"

  • nativescript-videoplayer: "~5.0.0"

  • nativescript-wearos: "~3.0.0"

  • nativescript-watchos-connector: "~2.0.0"

  • nativescript-inappbrowser: "~3.0.0"

  • @bradmartin/nativescript-urlhandler: "~2.0.0"

  • @klippa/nativescript-http: "~2.0.0"

  • @klippa/nativescript-login: "~2.0.0"

  • @triniwiz/nativescript-toasty: "~4.0.0"


Last updated: 11/15/2020

If a plugin has been updated but is missing from this list, please leave a comment indicating the plugin name and version that works with NativeScript 7. For example:

Add plugin-name@1.2.3 to the list.